Hallo, Besucher der Thread wurde 1,7k aufgerufen und enthält 31 Antworten

letzter Beitrag von Powerrudi am

Ladefehler Tracks.bin

  • Hallo Leute


    Bekomme seit gestern Abend, egal welches Strecken-Addon ich auch fahren möchte, selbst bei meinem selbst erstellten Karriere-Szenarion, immer die Fehlermeldung "Ladefehler Datei kann nicht geladen werden Tracks.bin".


    Nun habe ich mal ein bisschen im I-net recherchiert und alle dort angebotenen Lösungen haben zu keinem Erfolg geführt, da ich ja nicht genau weiß, welchen Strecke betroffen ist. Habe TS2020 auch schon 3x hintereinander über Steam überprüfen lassen, mal waren es 11 fehlerhafte Datain, dann widerum nur 3, aber alles hat nicht den gewünschten Erfolg gebracht - die Fehlermeldung bleibt.


    Hat jemand von Euch eine zündende Idee, ohne das ich gleich TS2020 komplett deinstallieren und wieder neu installieren muß?


    Gruß

    Powerrudi

  • Das wie Waeshoe schon sagte, nachsehen ob vorhanden, und welche größe die Datei hat. Bei 0KB ist die tracks.bin zerschossen, eine Neuinstallation der Strecke sollte das Regeln.


    Ansonsten betroffene(n) Strecke(n) jeweiligen Strecken Ordner in Content/Routes per Hand löschen und dann neuinstallieren.

  • Welche Strecke meldet beim Laden deine Fehlermeldung?


    Nehmen wir mal ein Bsp. z.b. Castle Rock.


    Dann gehe ich im TS Hauptmenü auf Erstellen, bleibe oben am Reiter bei Strecke, suche in der Liste nach Castle Rock. Klicke diese an, dann öffnet sich rechts dieses Fenster:



    Dann siehst du den Namen des Ordner der Strecke, und navigierst dann dort hin.


    Dort dann nach der tracks.bin Datei sehen.


    so kann man das bei jeder Strecke machen.


    (Bild ist aus dem Netz, hatte gerade keine Zeit den TS aufzumachen)

  • Grundsätzlich:
    Die Installation von TS auf einer separaten Partition ist immer eine gute Idee. Da kannst du mit 7z ein Backup machen, es auf einem Stick oder mobilen HDD abspeichern, bei Bedarf die ganze Partition formatieren und mit 7z ein Restore zurückschreiben. Das erspart dir viel Ungemach. Ok? Die jetzige Fragerei wäre dir sicher erspart geblieben.

    In deinem Fall versuche bitte herauszufinden, welchen Provider bzw. welche Routen es betrifft, denn dazu hast du noch nichts geschrieben. Dann können wir dir am ehesten helfen. Alle Tracks (Schienen) können nicht betroffen sein. Im einfachsten Fall installierst du die Route (nicht nur das Szenario) neu. Damit werden alle Dateien der betroffenen Route überschrieben. Du musst also nicht lange suchen.


    Es besteht auch die Möglichkeit, das von einzelnen Szenarios spezielles Schienenmaterial erwartet wird. Das steht dann jedoch in der Redme und du musst sie nachinstallieren. Solche Fälle gibt es jede Menge.
    Schwerer wird es, falls es eine Route ist, die dir bei der Installation von TS beigelegt wurde. Da kommst du wahrscheinlich um eine saubere Neuinstallation nicht herum. Diese kannst du ebenfalls mit 7z sichern und das Restore bei ähnlichen Katastrophen zurückschreiben.

    Wichtig:
    Solltest du später einmal TS, eine Route, ein Szenario oder/und ein Objekt zurückschreiben, wird der Rest von TS nicht beschädigt oder gelöscht, sondern nur der betroffene Teil überschrieben.

    Krasses Beispiel:
    Als ich auf TS2019 wechselte, habe ich lediglich den Inhalt des Programmverzeichnisses gelöscht und danach das neue Programm installiert. Alle bisher installierten Routen und Szenarios blieben mir unbeschädigt erhalten.

    Um es mal anders herum an meinem Beispiel zu erläutern:

    Ich mache regelmäßig ein komplettes Backup auf eine mobile Festplatte. Es wird fällig, wenn ich eine Route oder mehreres Rollmaterial installiert habe. Zusätzlich speichere ich alle heruntergeladenen DLCs in sortierten Archiven auf der mobilen HDD ab. Damit habe ich viel schneller einen Ersatz zur Hand. Den Händler musste ich noch nie fragen, denn es geht ihn aus Datenschutzgründen einen feuchten Kehricht an, was ich auf der Festplatte habe. Deshalb habe ich auch seinen Zugriff und Werbemüll mit Windows Firewall Control unterbunden.

  • ANZEIGE
  • Also gleich zu Anfang, der Button "Ordner öffnen" läßt sich bei mir nicht anklicken, der bleibt ausgegraut. Also habe ich mich daran gemacht, die Routen per Hand, jede einzeln im Steam ... Content -> Routes zu öffnen. Wie gesagt, sind 101 Ordner. Dann habe ich in jedem Ordner den Ordner "Networks" geöffnet, da steht ja die Tracks.bin drinnen und in allen Ordnern, die den Ordner Networks beinhalten, da gibt es keine Tracks.bin mit 0KB. Ausser in einem Ordner mit der Nr. 59bc1d8f-c322-49b0-81c6-5a031bb4b726 da steht absolut nix drinnen. Der ist vollkommen leer.


    Ich habe diesen leeren Ordner mal Ausgeschnitten und auf den Desktop gelegt. Vielleicht liegt es ja daran.

  • @Hinterwaeldler


    Doch habe ich ganz am Anfang schon geschrieben, im 1. Absatz:

    Wie gesagt, egal welche Strecke ich fahren möchte, nach dem Laden erhalte ich die Fehlermeldung Szenario-Ladefehler Datei kann nicht geladen werden - Tracks.bin. Demzufolge würde es alle Strecken betreffen, eingeschlossen derer, die ich selbst erstellt habe. Ich habe mir unlängst über Steam auch eine Sicherung des Spiels TS2020 gemacht, da hatte ich diese Tracks.bin Fehlermeldung noch nicht.

  • Doch, ich leere regelmäßig den Cache, selbst wenn ich über Steam eine Datenüberprüfung des Spiels mache und mir Steam sagt, 11 Dateien fehlerhaft und neu aufgespielt. Wie gesagt, die Fehlermeldung ist gestern Abend zum ersten mal aufgetreten, nachdem ich den Blindzug von TTB vor ein Af-Signal gesetzt habe, damit dieses für ca. 5 Minuten Hp0 anzeigt.


    Habe da auch schon was in meinem Thema Blindzug von TTB hier im Forum geschrieben. Hier mal der Auszug:

  • Betrifft das wirklich alle Strecken, die Du installiert hast? Dann ist die Frage, ob die wirklich alle mit denselben Gleisen ausgestattet sind. Falls nicht, vermute ich mal, dass der Fehler nicht bei den Tracks.bin direkt liegt, sondern an dem Umstand, dass auf diese nicht mehr zugegriffen werden kann.


    Ist es dann noch möglich, dass der Blindzug irgendetwas zerschossen hat, was das oben beschriebene ausgelöst hat?

  • Ja, bislang betrifft das alle Strecken, die ich installiert habe, eingeschlossen der selbst erstellten Szenarios. Diese Ladefehlermeldung hat auf dem selbst erstellten Szenario (Berlin-Leipzig KBS 220) gestern Abend begonnen, als ich eine Testfahrt machen wollte. Ob der Blindzug jetzt was zerschossen hat, kann ich nicht beantworten. Ich weiß nur, das er nicht das gemacht hat, was er eigentlich sollte.


    Also, ich habe gestern Abend ein Karriere-Szenario von der Strecke Leipzig-Berlin KBS 220 erstellt, mit den originalen Daten der Strecke. Meinen ICE4 in Berlin Gesundbrunnen auf Gleis 7 gestellt, Nun die Markierung Nebengleis für An- und Durchsagen auf die entsprechenden Gleise gesetzt und nun den Fahrplan von Berlin Gesundbrunnen bis Leipzig Hbf Gleis 14 erstellt. Zu guter letzt habe ich den Blindzug von TTB auf Gleis 7 vor das Af-Signal gesetzt und extra ein neues Portal, nur für den Blindzug. Habe noch dem Blindzug einen Lokführer zugewiesen und die Abfahrtzeit eingetragen, nebst Angaben zum Portal, wo dieser verschwinden soll.


    Jetzt eine Testfahrt im Szenario gestartet und wolla, nix geht mehr - rea ne va plu - Szenario-Ladefehler Datei kann nicht geladen werden - Tracks.bin - mehr hab ich eigentlich gar nicht gemacht. Achso, den introtext hab ich noch geschrieben im ScenarioScripting. Das wars. Aber wie ich schon oben unter #11 geschrieben habe, habe ich alle Ordner im Content ->Routes->Networks einzeln geöffnet und in keinem war eine Tracks.bin die 0KB hatte. Jetzt bin ich ratlos.


    Habe soeben mal mein selbst erstelltes Karriere-Szenario gestartet, um zu sehen, ob es etwas mit dem leeren Ordner zu tun hat, den ich (siehe oben unter #12) mal aus den Content->Routes entfernt habe.

  • Dann sieht es wirklich danach aus, als dass der Blindzug etwas damit zu tun hat, da dieser ja von Anfang an nicht so ganz funktioniert hat, wie es zu erwarten war.


    Mit den Möglichkeiten und den Funktionen des Editors habe ich mich noch nicht so beschäftigt. Aber könnte man statt dem Bilndzug auch eine Markierung setzen, die erst passiert werden muss und damit der Timer für die Signalschaltung gestartet wird? In Lets-Plays ist auf eine ähnliche Weise eine Durchsage für den nächsten Bahnhof gesteuert worden, nur, dass diese sofort ausgelöst wurde.


    Als zweite Möglichkeit ging dies aber auch über eine Zeitsteuerung, wo aber die Durchsage bei Verspätungen viel zu früh kommt. Lässt sich das nicht irgendwie kombinieren? Dann hast Du das gewünschte Ergebnis ohne Blindzug.

  • ANZEIGE